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Missing GinaDll error message upon boot Missing GinaDll error message upon boot



Symptom:

On a PC that has a SoftXpand installation Windows cannot boot. Error message appears on screen: “Missing DLL file C:\program files\Miniframe\SoftXpand\MfOsGine.dll” with only one option to restart the computer.

Cause:

Probably corrupted MfOsGina.dll file caused by setup problem, or some incompatibility to the OS.

Resolution:

To resolve this issue you need to:

  • Access the registry path: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon
  • Delete the GinaDll in the registry.
    This will enable Windows to start again.
  • Then Remove SoftXpand.
  • Finalize Windows activation, Windows genuine validation and all other Windows updates and maintenance.
  • Reinstall SoftXpand.


Details:

In order to fix the registry data in a non bootable Windows XP you have 2 options:

Option 1 – connect the HDD to a bootable Windows computer and fix the registry data:


  1. Remove the HDD from the computer, connect it to a bootable Windows PC and start Windows.
  2. Type Regedit.exe in the prompt, and press Enter. Select the HKEY_USERS hive.

  3. From the File menu, choose the Load Hive option. Browse to your Windows installation drive, for example the following location: G:\Windows\System32\Config\

  4. Select the file named SOFTWARE (the file without any extensions), and click Open.

  5. Type a name for the hive that you've loaded now. (Example: MyXPHive).

  6. Now the SOFTWARE hive is loaded, and present under the HKEY_USERS base hive.
  7. In order to delete the GinaDll in the loaded hive, navigate to the following location
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon
  8. Delete Giandll.

  9. After deleting GinaDll, you MUST unload the Hive. To do so, select MyXPHive branch, and then in the File menu, choose Unload Hive. It's important to note that you'll need to select the MyXPHive branch first, before unloading it.

  10. Replace back the HDD to the initial PC.


Option 2 – Boot using BartPE and fix registry data:

  1. Insert the BartPE CD into the drive, and boot the system from the CD. Once the file loading phase is over, the Bart PE desktop will be visible, as shown in picture below.



    To learn how to create BartPE bootable CD see this link:
    http://www.winhelponline.com/blog/create-bartpe-bootable-cd-using-pe-builder.
  2. Follow steps 2-9 as in option 1 above.
  3. Quit BartPE and restart Windows.
Article is in the following categories:
KB » Troubleshooting



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